Apple Watch help: Everything you need to know about your smartwatch

Android phones are not compatible with any Apple Watch. The minimum requirements for an iPhone user are that you have an iPhone 5 or later running at least iOS 8.2. Yes. Simply head into the settings …
( read original story …)